BEST MICROSCOPE FOR DELL INSPIRON 15 _\- 7000 SERIES

Discussion in 'Coin Roll Hunting' started by CREATIVECRHUNTER, May 11, 2020.

  1. Hello Coinhunter Pros!

    I have been out of the coinhunting hobby for almost 4 years and am getting back in.

    My original microscope (Microcapture Pro USB Digital Microscope)
    no longer works due to WINDOWS 10 Updates.

    Can I get some help as to what type of microscope I need to be compatible with this computer, and the Windows update?

    Thank you for your help and assistance.
     
  2. Avatar

    Guest User Guest



    to hide this ad.
  3. JickyD

    JickyD Active Member

    I can't answer your question, but I've had problems with my old and new scopes not working with my newer laptop/software. The old one, which worked great, lost it's zoom capabilities when I got a new souped-up laptop. So I bought a new one, but the picture resolution is so small as to be worthless. I even have a third which has similar issues with my new HP laptop. I tried contacting help support, and the closest I could come to understanding the problem is it has something to do with the way my video board processes the video from the scope. Driver updates don't help. Makes me mad because I don't have any confidence that if I buy another it'll be any better.
     
    alurid likes this.
  4. I puchased the microscope below, back in January but the quality of resolution is grainy and it seems impossible to see or take a picture of the entire coin - even as small as a penny.

    Koolertron 4.3 inch 1080P LCD

    My original scope was a fraction of the price - and took great, clean, clear shots.

    I'm stuck until I can solve this issue.

    I appreciate your input.

    Hopefully, someone out there has found the answer and will share it with us.

    Thank you so much.
     
  5. Hunting SW Ohio

    Hunting SW Ohio New Member

    I have one from pluggable technologies. It works great. I found it on rob finds treasure's web site. I would recommend it. I runs around 35 or 40 dollars
     
  6. JickyD

    JickyD Active Member

    The Pluggable Technology one was my original scope, which the zoom no longer works once I upgraded my laptop. It worked great with my old laptop though. :-(
     
Draft saved Draft deleted

Share This Page